Tag Archives: Released

PowerShell 4.0 Update available for 2012/2008R2/Windows 7

New PowerShell 4.0 updates have been released, part of the Windows Management Framework 4.0 (WMF 4.0). With WMF 5.0 released and then later temporarily retracted from the download center there might be some confusion about who this patch is for, I hope to clear up some of that in this blog post.

So first and foremost, this is a PowerShell 4.0 Update package now also released for Windows Server 2012/2008 R2 SP1 and Windows 7SP1. This upgrade package contains some improvements in regards to DSC and PowerShell logging, please refer to the following two blog articles by the PowerShell team for full details:
Windows Management Framework (WMF) 4.0 Update now available…
Windows Management Framework (WMF) 4.0 Update is coming your way

So more importantly who is this patch intended for, from my perspective this patch is for the following situations:

  • You have WMF 4.0 installed and are in need of the features and fixes offered by this patch
  • Upgrading to PowerShell 5.0 (once it is re-released) is not an option because of incompatibilities which prevent you from upgrading
  • You are in an enterprise environment where roll-outs of completely new versions is limited but patching is possible
  • You are a curious individual and would like to play with the latest, supported, version of PowerShell on your version of Windows

WMF40Update

For more information about what is new in this update, please refer to the following article:
What’s New in Windows PowerShell

The WMF 4.0 updates are currently available as a separate downloads for the following Windows versions:

Operating System Service Pack Prerequisites UPDATE
Windows Server 2012 WMF 4.0 is installed and .NET Framework 4.5 KB3119938
Windows Server 2008 R2 SP1 WMF 4.0 is installed and .NET Framework 4.5 KB3109118
Windows 7 SP1 WMF 4.0 is installed and .NET Framework 4.5 KB3109118

For more information these WMF 4.0 Updates and the links in this article please refer to the links below:

Links in this Article
Windows Management Framework (WMF) 4.0 Update now available…
Windows Management Framework (WMF) 4.0 Update is coming your way
What’s New in Windows PowerShell

Share

PowerShell 5.0 RTM available for download

PowerShell 5.0, part of the Windows Management Framework 5.0 (WMF 5.0), is now released and available in the Microsoft Download Center.

WMF5Released

WMF 5.0 is currently available as a separate download for the following Windows versions:

Operating System Service Pack Prerequisites
Windows Server 2012 R2 .NET Framework 4.5 or above
Windows Server 2012 .NET Framework 4.5 or above
Windows Server 2008 R2 SP1 WMF 4.0 is installed and .NET Framework 4.5 or above
Windows 8.1
Windows 7 SP1 WMF 4.0 is installed and .NET Framework 4.5 or above

Currently WMF 5.0 RTM can be installed on older Windows clients, Windows 7 and Windows 8.1,  the updates can be downloaded. On Windows 10 WMF 5.0 is not available as an additional download as Windows Update can be used to update the Windows Management Framework.

Before installing WMF 5.0 on your system, please make sure that you read the released notes as there are currently known incompatibilities with the following products:

  • Microsoft Exchange Server 2013
  • Microsoft Exchange Server 2010 SP3
  • Microsoft SharePoint Server 2013
  • Microsoft SharePoint Server 2010
  • System Center 2012 Virtual Machine Manager

For more information please refer to the Windows Management Framework (WMF) 5.0 RTM Release Notes Overview on MSDN.

For more information on WMF 5.0 and the links in this article please refer to the links below:

Links in this Article
Windows Management Framework 5.0 Download
Windows Management Framework (WMF) 5.0 RTM Release Notes Overview
Known Incompatibilities
PowerShell Team – Windows Management Framework (WMF) 5.0 RTM is now available
Windows Management Framework (WMF) 5.0 currently removed from Download Center
Share